Package vulnerability, severity high
node-forge: Forge: X.509 basicConstraints bypass in verifyCertificateChain() via deprecated extension OIDs 2.5.29.10 and 2.5.29.13
Published , updated
Forge: X.509 basicConstraints bypass in verifyCertificateChain() via deprecated extension OIDs 2.5.29.10 and 2.5.29.13. Source: GHSA-5x38-2vff-x55p (CVE-2026-119190).
What's affected
- node-forge (npm)<1.4.1
What to do
- Upgrade node-forge to 1.4.1 or later.
Check whether you were affected
Pharon tells teams automatically when this affects something they run. To check a machine, run this in Claude Code with the Pharon plugin, in the repository that uses it:
/pharon:check-incident ghsa-5x38-2vff-x55pReferences
- https://osv.dev/vulnerability/GHSA-5x38-2vff-x55p
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-5x38-2vff-x55p
- https://nvd.nist.gov/vuln/detail/CVE-2026-119190
- https://github.com/digitalbazaar/forge/commit/58c06bc251856b409c30ecb35a93f5f6c9bbc84a
- https://github.com/digitalbazaar/forge
- https://github.com/digitalbazaar/forge/releases/tag/v1.4.1
Notice ghsa-5x38-2vff-x55p, signed with key feed-prod-2026-10 (Ed25519). The Pharon CLI verifies the signature before using a notice.