Package vulnerability, severity high
Langflow critical flaws allow unauthenticated auth bypass and remote code execution (1.0.0-1.12.8)
Published
Two critical flaws in Langflow let a remote attacker with no account bypass authentication or run arbitrary code on the server. IBM, which handles Langflow vulnerability reports, disclosed them. Every release from 1.0.0 through 1.12.8 is affected, and the only fix is version 1.13.0.
What's affected
- langflow (pypi)>=1.0.0 <1.13.0
What to do
- Upgrade Langflow to version 1.13.0, the only fixed release.
- Until you can upgrade, avoid exposing Langflow servers running 1.0.0 through 1.12.8 to untrusted networks.
Check whether you were affected
Pharon tells teams automatically when this affects something they run. To check a machine, run this in Claude Code with the Pharon plugin, in the repository that uses it:
/pharon:check-incident langflow-unauth-rce-2026-11References
Notice langflow-unauth-rce-2026-11, signed with key feed-prod-2026-10 (Ed25519). The Pharon CLI verifies the signature before using a notice.